L'errore: Warning Parameter 1 to modMainMenuHelper::buildXML() expected to be a reference vuol dire che la versione installata di joomla non e' compatibile con PHP 5.3.x .

Per risolvere il problema basta aggiornare joomla alla versione 1.5.17 o superiore.